summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2017-05-25 04:36:24 +0000
committerEric Fiselier <eric@efcs.ca>2017-05-25 04:36:24 +0000
commit737c3bf25ec897ec6e461644ef3658a52798e2ff (patch)
tree3902c3d86306bc86647e7b4df99c5db087408729 /CMakeLists.txt
parent8392d4940d7b419ecda0334564368aa9b6a7475e (diff)
Add <experimental/coroutine>
This patch adds the library portions of the coroutines PDTS, which should now be supported by Clang. git-svn-id: https://llvm.org/svn/llvm-project/libcxx/trunk@303836 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8c25a0a0e..33d888b80 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -452,6 +452,11 @@ add_compile_flags_if_supported(-nostdinc++)
# the dylib when get ODR used by another function.
add_compile_flags_if_supported(-fvisibility-inlines-hidden)
+if (LIBCXX_CONFIGURE_IDE)
+ # This simply allows IDE to process <experimental/coroutine>
+ add_compile_flags_if_supported(-fcoroutines-ts)
+endif()
+
# Let the library headers know they are currently being used to build the
# library.
add_definitions(-D_LIBCPP_BUILDING_LIBRARY)