summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Fiselier <eric@efcs.ca>2017-03-02 21:55:03 +0000
committerEric Fiselier <eric@efcs.ca>2017-03-02 21:55:03 +0000
commit0cbd39f03a4d10e0d6c58f8fda07ca1dbfb3b0cb (patch)
treeef02979184f30182d02d74dc9a6f85d5c63444a5 /CMakeLists.txt
parentf282bc8767e881d9cd0f95e84a6fb8ced7f733e1 (diff)
Work around GCC linking errors within libc++abi due to missing new/delete definitions
git-svn-id: https://llvm.org/svn/llvm-project/libcxx/trunk@296822 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 03e0f68db..45ef0c01f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -159,7 +159,12 @@ option(LIBCXX_ENABLE_ABI_LINKER_SCRIPT
set(ENABLE_NEW_DELETE_DEFAULT ON)
if (LIBCXXABI_ENABLE_NEW_DELETE_DEFINITIONS)
- set(ENABLE_NEW_DELETE_DEFAULT OFF)
+# FIXME: This option should default to off. Unfortunatly GCC 4.9 fails to link
+# programs to due undefined references to new/delete in libc++abi so to work
+# around this libc++abi currently defaults LIBCXXABI_ENABLE_NEW_DELETE_DEFINITIONS
+# to ON. Once the GCC bug has been worked around this option should be changed
+# back to OFF.
+ set(ENABLE_NEW_DELETE_DEFAULT ON)
endif()
option(LIBCXX_ENABLE_NEW_DELETE_DEFINITIONS