summaryrefslogtreecommitdiff
path: root/lib/scudo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/scudo/CMakeLists.txt')
-rw-r--r--lib/scudo/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/lib/scudo/CMakeLists.txt b/lib/scudo/CMakeLists.txt
index 1e03fcd40..3adfe6882 100644
--- a/lib/scudo/CMakeLists.txt
+++ b/lib/scudo/CMakeLists.txt
@@ -25,10 +25,11 @@ set(SCUDO_OBJECT_LIBS
if (FUCHSIA)
list(APPEND SCUDO_CFLAGS -nostdinc++)
list(APPEND SCUDO_DYNAMIC_LINK_FLAGS -nostdlib++)
- # TODO(kostyak): remove when stacktraces are split off of RTSanitizerCommon
- list(APPEND SCUDO_DYNAMIC_LIBS unwind_shared)
else()
- list(APPEND SCUDO_OBJECT_LIBS RTSanitizerCommonCoverage RTUbsan)
+ list(APPEND SCUDO_OBJECT_LIBS
+ RTSanitizerCommonCoverage
+ RTSanitizerCommonSymbolizer
+ RTUbsan)
list(APPEND SCUDO_DYNAMIC_LIBS ${SANITIZER_CXX_ABI_LIBRARY})
endif()