summaryrefslogtreecommitdiff
path: root/lib/lsan/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/lsan/CMakeLists.txt')
-rw-r--r--lib/lsan/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/lib/lsan/CMakeLists.txt b/lib/lsan/CMakeLists.txt
index beb9c8aa4..378f08199 100644
--- a/lib/lsan/CMakeLists.txt
+++ b/lib/lsan/CMakeLists.txt
@@ -45,4 +45,7 @@ if (NOT APPLE AND NOT ANDROID)
endforeach()
endif()
-add_subdirectory(tests)
+if (LLVM_INCLUDE_TESTS)
+ add_subdirectory(tests)
+endif()
+add_subdirectory(lit_tests)