summaryrefslogtreecommitdiff
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 3a5d4297e..009c59f4d 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -4,8 +4,11 @@
include(AddCompilerRT)
include(SanitizerUtils)
-if(COMPILER_RT_HAS_SANITIZER_COMMON)
+if(COMPILER_RT_HAS_INTERCEPTION)
add_subdirectory(interception)
+endif()
+
+if(COMPILER_RT_HAS_SANITIZER_COMMON)
add_subdirectory(sanitizer_common)
add_subdirectory(lsan)
add_subdirectory(ubsan)