summaryrefslogtreecommitdiff
path: root/test/ubsan/CMakeLists.txt
diff options
context:
space:
mode:
authorRoman Lebedev <lebedev.ri@gmail.com>2017-12-01 19:36:29 +0000
committerRoman Lebedev <lebedev.ri@gmail.com>2017-12-01 19:36:29 +0000
commitd3de79598999329c71a7fa2fc63c0e33a89098d1 (patch)
treecd403088309d62d5efe0dff8ba6428e9fbef4df8 /test/ubsan/CMakeLists.txt
parent420cd9e1652eda30d87cf9e5ce9cf25eb23c4b0f (diff)
[ubsan] Re-commit: lit changes for lld testing, future lto testing.
Summary: As discussed in https://github.com/google/oss-fuzz/issues/933, it would be really awesome to be able to use ThinLTO for fuzzing. However, as @kcc has pointed out, it is currently undefined (untested) whether the sanitizers actually function properly with LLD and/or LTO. This patch is inspired by the cfi test, which already do test with LTO (and/or LLD), since LTO is required for CFI to function. I started with UBSan, because it's cmakelists / lit.* files appeared to be the cleanest. This patch adds the infrastructure to easily add LLD and/or LTO sub-variants of the existing lit test configurations. Also, this patch adds the LLD flavor, that explicitly does use LLD to link. The check-ubsan does pass on my machine. And to minimize the [initial] potential buildbot breakage i have put some restrictions on this flavour. Please review carefully, i have not worked with lit/sanitizer tests before. The original attempt, r319525 was reverted in r319526 due to the failures in compiler-rt standalone builds. Reviewers: eugenis, vitalybuka Reviewed By: eugenis Subscribers: #sanitizers, pcc, kubamracek, mgorny, llvm-commits, mehdi_amini, inglorion, kcc Differential Revision: https://reviews.llvm.org/D39508 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@319575 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/ubsan/CMakeLists.txt')
-rw-r--r--test/ubsan/CMakeLists.txt33
1 files changed, 26 insertions, 7 deletions
diff --git a/test/ubsan/CMakeLists.txt b/test/ubsan/CMakeLists.txt
index 5843e0cb8..779168147 100644
--- a/test/ubsan/CMakeLists.txt
+++ b/test/ubsan/CMakeLists.txt
@@ -3,9 +3,20 @@ set(UBSAN_LIT_TESTS_DIR ${CMAKE_CURRENT_SOURCE_DIR})
set(UBSAN_TESTSUITES)
set(UBSAN_TEST_DEPS ${SANITIZER_COMMON_LIT_TEST_DEPS})
-macro(add_ubsan_testsuite test_mode sanitizer arch)
+macro(add_ubsan_testsuite test_mode sanitizer arch lld thinlto)
set(UBSAN_LIT_TEST_MODE "${test_mode}")
- set(CONFIG_NAME ${UBSAN_LIT_TEST_MODE}-${arch})
+ set(CONFIG_NAME ${UBSAN_LIT_TEST_MODE})
+ if (${lld})
+ set(CONFIG_NAME ${CONFIG_NAME}-lld)
+ list(APPEND UBSAN_TEST_DEPS lld)
+ endif()
+ if (${thinlto})
+ set(CONFIG_NAME ${CONFIG_NAME}-thinlto)
+ list(APPEND UBSAN_TEST_DEPS LTO)
+ endif()
+ set(UBSAN_TEST_USE_LLD ${lld})
+ set(UBSAN_TEST_USE_THINLTO ${thinlto})
+ set(CONFIG_NAME ${CONFIG_NAME}-${arch})
configure_lit_site_cfg(
${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.in
${CMAKE_CURRENT_BINARY_DIR}/${CONFIG_NAME}/lit.site.cfg)
@@ -15,6 +26,14 @@ macro(add_ubsan_testsuite test_mode sanitizer arch)
endif()
endmacro()
+macro(add_ubsan_testsuites test_mode sanitizer arch)
+ add_ubsan_testsuite(${test_mode} ${sanitizer} ${arch} False False)
+
+ if(COMPILER_RT_HAS_LLD AND arch STREQUAL "x86_64" AND NOT (APPLE OR WIN32))
+ add_ubsan_testsuite(${test_mode} ${sanitizer} ${arch} True False)
+ endif()
+endmacro()
+
set(UBSAN_TEST_ARCH ${UBSAN_SUPPORTED_ARCH})
if(APPLE)
darwin_filter_host_archs(UBSAN_SUPPORTED_ARCH UBSAN_TEST_ARCH)
@@ -23,20 +42,20 @@ endif()
foreach(arch ${UBSAN_TEST_ARCH})
set(UBSAN_TEST_TARGET_ARCH ${arch})
get_test_cc_for_arch(${arch} UBSAN_TEST_TARGET_CC UBSAN_TEST_TARGET_CFLAGS)
- add_ubsan_testsuite("Standalone" ubsan ${arch})
+ add_ubsan_testsuites("Standalone" ubsan ${arch})
if(COMPILER_RT_HAS_ASAN AND ";${ASAN_SUPPORTED_ARCH};" MATCHES ";${arch};")
# TODO(wwchrome): Re-enable ubsan for asan win 64-bit when ready.
# Disable ubsan with AddressSanitizer tests for Windows 64-bit.
if(NOT OS_NAME MATCHES "Windows" OR CMAKE_SIZEOF_VOID_P EQUAL 4)
- add_ubsan_testsuite("AddressSanitizer" asan ${arch})
+ add_ubsan_testsuites("AddressSanitizer" asan ${arch})
endif()
endif()
if(COMPILER_RT_HAS_MSAN AND ";${MSAN_SUPPORTED_ARCH};" MATCHES ";${arch};")
- add_ubsan_testsuite("MemorySanitizer" msan ${arch})
+ add_ubsan_testsuites("MemorySanitizer" msan ${arch})
endif()
if(COMPILER_RT_HAS_TSAN AND ";${TSAN_SUPPORTED_ARCH};" MATCHES ";${arch};" AND NOT ANDROID)
- add_ubsan_testsuite("ThreadSanitizer" tsan ${arch})
+ add_ubsan_testsuites("ThreadSanitizer" tsan ${arch})
endif()
endforeach()
@@ -45,7 +64,7 @@ if(APPLE)
set(UBSAN_TEST_TARGET_ARCH ${arch})
get_test_cc_for_arch(${arch} UBSAN_TEST_TARGET_CC UBSAN_TEST_TARGET_CFLAGS)
set(UBSAN_TEST_TARGET_CFLAGS "${UBSAN_TEST_TARGET_CFLAGS} -lc++abi")
- add_ubsan_testsuite("StandaloneStatic" ubsan ${arch})
+ add_ubsan_testsuites("StandaloneStatic" ubsan ${arch})
endforeach()
endif()