summaryrefslogtreecommitdiff
path: root/test/tsan/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <vonosmas@gmail.com>2016-02-23 01:34:17 +0000
committerAlexey Samsonov <vonosmas@gmail.com>2016-02-23 01:34:17 +0000
commit4f87e957770c76d8cb729346ce3e2c1f764b58e9 (patch)
treee4c32edef2a4d7ed16e60f2ea755c11eb2bda7d0 /test/tsan/CMakeLists.txt
parent250dd5e3f5d3b125d5bd269a97b3f0f2a8d63f25 (diff)
[tests] Always specify correct config.target_arch when configuring test suite.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@261601 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/tsan/CMakeLists.txt')
-rw-r--r--test/tsan/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/tsan/CMakeLists.txt b/test/tsan/CMakeLists.txt
index a05860265..c6cb985fc 100644
--- a/test/tsan/CMakeLists.txt
+++ b/test/tsan/CMakeLists.txt
@@ -22,6 +22,7 @@ if(APPLE)
endif()
foreach(arch ${TSAN_TEST_ARCH})
+ set(TSAN_TEST_TARGET_ARCH ${arch})
string(TOLOWER "-${arch}" TSAN_TEST_CONFIG_SUFFIX)
if(ANDROID OR ${arch} MATCHES "arm|aarch64")
# This is only true if we are cross-compiling.