summaryrefslogtreecommitdiff
path: root/test/timing/CMakeLists.txt
diff options
context:
space:
mode:
authorEdward O'Callaghan <eocallaghan@auroraux.org>2009-08-03 01:08:25 +0000
committerEdward O'Callaghan <eocallaghan@auroraux.org>2009-08-03 01:08:25 +0000
commitd904635616ca27a56531375a7d25547c930a4040 (patch)
tree2debf48933b911292580b8ed393f7f19017f78d2 /test/timing/CMakeLists.txt
parentad9a17686dff730aa89f181b22ab4ec827d40be2 (diff)
Initial import of CMake type build system. Just like the rest of llvm..
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@77933 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/timing/CMakeLists.txt')
-rw-r--r--test/timing/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/test/timing/CMakeLists.txt b/test/timing/CMakeLists.txt
new file mode 100644
index 000000000..4368731be
--- /dev/null
+++ b/test/timing/CMakeLists.txt
@@ -0,0 +1,23 @@
+PROJECT( timing )
+
+SET( SRCS
+ lshrdi3.c
+ floatundixf.c
+ floatdixf.c
+ umoddi3.c
+ udivdi3.c
+ negdi2.c
+ ashrdi3.c
+ muldi3.c
+ ashldi3.c
+ divdi3.c
+ floatundisf.c
+ floatdidf.c
+ floatdisf.c
+ moddi3.c
+ floatundidf.c
+ )
+
+ADD_LIBRARY( ${PROJECT_NAME} SHARED ${SRCS})
+# ADD_EXECUTABLE( ${PROJECT_NAME} ${SRCS} )
+# TARGET_LINK_LIBRARIES( ${PROJECT_NAME} ${LIBS} )