summaryrefslogtreecommitdiff
path: root/test/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-08-20 17:46:58 +0000
committerChris Bieneman <beanz@apple.com>2015-08-20 17:46:58 +0000
commitf96e5818977b9139f0a4ec60f3debb7b98971e8a (patch)
tree3994d4b1de9a9f1662db215823eee5e6e5fe78f8 /test/sanitizer_common/CMakeLists.txt
parent2bb043561c6c82c396e3ff4944e31d283d32ae40 (diff)
[CMake] Fixing r245581 based on feedback from Filcab.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@245582 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/sanitizer_common/CMakeLists.txt')
-rw-r--r--test/sanitizer_common/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/sanitizer_common/CMakeLists.txt b/test/sanitizer_common/CMakeLists.txt
index 801283ef0..54b913527 100644
--- a/test/sanitizer_common/CMakeLists.txt
+++ b/test/sanitizer_common/CMakeLists.txt
@@ -31,7 +31,7 @@ foreach(tool ${SUPPORTED_TOOLS})
# This is only true if we're cross-compiling.
set(SANITIZER_COMMON_TEST_TARGET_CFLAGS
${COMPILER_RT_TEST_COMPILER_CFLAGS})
- elseif(NOT APPLE)
+ else()
get_target_flags_for_arch(${arch} SANITIZER_COMMON_TEST_TARGET_CFLAGS)
string(REPLACE ";" " " SANITIZER_COMMON_TEST_TARGET_CFLAGS "${SANITIZER_COMMON_TEST_TARGET_CFLAGS}")
endif()