summaryrefslogtreecommitdiff
path: root/test/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-02-20 12:18:08 +0000
committerAlexey Samsonov <samsonov@google.com>2014-02-20 12:18:08 +0000
commitc7831b17590a6754e3471a995cc56a569318c172 (patch)
tree47afcb39af91fa1f75e131629f5a8f0007e1b3e5 /test/sanitizer_common/CMakeLists.txt
parente20c23ce1585d3b49cbe3c127b88d3ef1bbc7c41 (diff)
Move config for sanitizer_common tests under test/ for consistency
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@201779 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/sanitizer_common/CMakeLists.txt')
-rw-r--r--test/sanitizer_common/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/test/sanitizer_common/CMakeLists.txt b/test/sanitizer_common/CMakeLists.txt
new file mode 100644
index 000000000..f028be8f2
--- /dev/null
+++ b/test/sanitizer_common/CMakeLists.txt
@@ -0,0 +1,9 @@
+if(COMPILER_RT_INCLUDE_TESTS)
+ configure_lit_site_cfg(
+ ${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.in
+ ${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg)
+ add_lit_testsuite(check-sanitizer "Running sanitizer library unittests"
+ ${CMAKE_CURRENT_BINARY_DIR}
+ DEPENDS SanitizerUnitTests)
+ set_target_properties(check-sanitizer PROPERTIES FOLDER "Sanitizer unittests")
+endif()