summaryrefslogtreecommitdiff
path: root/test/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Sanders <daniel.sanders@imgtec.com>2016-02-09 15:52:35 +0000
committerDaniel Sanders <daniel.sanders@imgtec.com>2016-02-09 15:52:35 +0000
commit22b12956bdb8bf93843965f279e190c1a2110609 (patch)
tree705bcb6ae37251cec39e7b7b2f916899280951a0 /test/sanitizer_common/CMakeLists.txt
parenta66a1a96d1498207dc0546ba8072504b4f8db04d (diff)
[sanitizer_common] Add suffix to lit testsuite name to distinguish subtargets.
Summary: This fixes duplicate test names in the test results, so: PASS: SanitizerCommon-asan :: fopen_nullptr.c (304 of 431) PASS: SanitizerCommon-asan :: fopen_nullptr.c (305 of 431) is now: PASS: SanitizerCommon-asan-i386-Linux :: fopen_nullptr.c (282 of 431) PASS: SanitizerCommon-asan-x86_64-Linux :: fopen_nullptr.c (316 of 431) Reviewers: samsonov Subscribers: llvm-commits Differential Revision: http://reviews.llvm.org/D16850 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@260227 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/sanitizer_common/CMakeLists.txt')
-rw-r--r--test/sanitizer_common/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/sanitizer_common/CMakeLists.txt b/test/sanitizer_common/CMakeLists.txt
index 54b913527..748547adf 100644
--- a/test/sanitizer_common/CMakeLists.txt
+++ b/test/sanitizer_common/CMakeLists.txt
@@ -36,6 +36,7 @@ foreach(tool ${SUPPORTED_TOOLS})
string(REPLACE ";" " " SANITIZER_COMMON_TEST_TARGET_CFLAGS "${SANITIZER_COMMON_TEST_TARGET_CFLAGS}")
endif()
set(CONFIG_NAME ${tool}-${arch}-${OS_NAME})
+ set(SANITIZER_COMMON_TEST_CONFIG_SUFFIX "-${arch}-${OS_NAME}")
configure_lit_site_cfg(
${CMAKE_CURRENT_SOURCE_DIR}/lit.site.cfg.in
${CMAKE_CURRENT_BINARY_DIR}/${CONFIG_NAME}/lit.site.cfg)