summaryrefslogtreecommitdiff
path: root/test/interception/CMakeLists.txt
diff options
context:
space:
mode:
authorBruno Cardoso Lopes <bruno.cardoso@gmail.com>2016-08-04 04:46:39 +0000
committerBruno Cardoso Lopes <bruno.cardoso@gmail.com>2016-08-04 04:46:39 +0000
commit8132fd7a9ff3dc3dd064d39e0ababc37c6e54ba2 (patch)
treec68da370cc82b3aa4eba4b8f0392e44051e9aa03 /test/interception/CMakeLists.txt
parented5529365d2559daab542eaf699444514de36340 (diff)
[Darwin] Exclude interception union tests on Darwin and Android
Since the directory is empty on Darwin, disable the inclusion and avoid the warning below. Exclude on Android as well to match the behavior from lib/interception/tests/CMakeLists.txt lit.py: /Users/buildslave/jenkins/sharedspace/clang-R_master@2/llvm/utils/lit/lit/discovery.py:224: warning: input '/Users/buildslave/jenkins/sharedspace/clang-R_master@2/clang-build/Build/tools/clang/runtime/compiler-rt-bins/test/interception/Unit' contained no tests This fixes the above warning in some of public bots, like http://lab.llvm.org:8080/green/job/clang-stage2-configure-Rlto_check/8686 Differential Revision: https://reviews.llvm.org/D23128 rdar://problem/27581108 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@277692 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/interception/CMakeLists.txt')
-rw-r--r--test/interception/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/test/interception/CMakeLists.txt b/test/interception/CMakeLists.txt
index 2b471ee31..ff9e4b0ad 100644
--- a/test/interception/CMakeLists.txt
+++ b/test/interception/CMakeLists.txt
@@ -1,8 +1,9 @@
set(INTERCEPTION_TEST_DEPS ${SANITIZER_COMMON_LIT_TEST_DEPS})
set(INTERCEPTION_TESTSUITES)
-# Unit tests.
-if(COMPILER_RT_INCLUDE_TESTS)
+# Unit tests. There are currently no unit tests capable to running on Apple or
+# Android targets.
+if(COMPILER_RT_INCLUDE_TESTS AND NOT ANDROID AND NOT APPLE)
configure_lit_site_cfg(
${CMAKE_CURRENT_SOURCE_DIR}/Unit/lit.site.cfg.in
${CMAKE_CURRENT_BINARY_DIR}/Unit/lit.site.cfg)