summaryrefslogtreecommitdiff
path: root/test/cfi/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Collingbourne <peter@pcc.me.uk>2015-03-16 22:00:04 +0000
committerPeter Collingbourne <peter@pcc.me.uk>2015-03-16 22:00:04 +0000
commit9c8af610aa852637031b4b316e8f37d9367d1973 (patch)
tree64d62853f83ea29c6ec8a9a1879fec1c4bc35ebc /test/cfi/CMakeLists.txt
parentfcfd88f49ac6becbe1f116822909264386625c9d (diff)
CFI: Make check-cfi depend on libLTO on Darwin.
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@232426 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/cfi/CMakeLists.txt')
-rw-r--r--test/cfi/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/cfi/CMakeLists.txt b/test/cfi/CMakeLists.txt
index 5750bd8a4..625e3ff11 100644
--- a/test/cfi/CMakeLists.txt
+++ b/test/cfi/CMakeLists.txt
@@ -15,6 +15,11 @@ if(NOT COMPILER_RT_STANDALONE_BUILD)
LLVMgold
)
endif()
+ if(APPLE)
+ list(APPEND CFI_TEST_DEPS
+ LTO
+ )
+ endif()
endif()
add_lit_testsuite(check-cfi "Running the cfi regression tests"