summaryrefslogtreecommitdiff
path: root/test/builtins/CMakeLists.txt
diff options
context:
space:
mode:
authorWeiming Zhao <weimingz@codeaurora.org>2017-03-29 03:36:46 +0000
committerWeiming Zhao <weimingz@codeaurora.org>2017-03-29 03:36:46 +0000
commit260f2c513bdffce646c53abc285fb1343afc9719 (patch)
tree26782ca89d7bb2be2e712fdc9265716e6be99b47 /test/builtins/CMakeLists.txt
parent4d2e2402a0106a7f45fd00c5a7708d786ee19217 (diff)
[Builtin] Unxfail tests for armhf
Summary: Originally, a few tests fail for armhf target due to: 1) COMPILER_RT_ARMHF_TARGET was not set when building the lib 2) COMPILER_RT_ABI should not be defined as `__attribute__((pcs("aapcs")))` for armhf when building for both lib and tests This address https://bugs.llvm.org//show_bug.cgi?id=32261 mulsc3_test.c is a newly exposed issue, which will be addressed separately. Reviewers: rengolin, compnerd Reviewed By: compnerd Subscribers: aemerson, llvm-commits, mgorny Differential Revision: https://reviews.llvm.org/D31448 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@298974 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/builtins/CMakeLists.txt')
-rw-r--r--test/builtins/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/test/builtins/CMakeLists.txt b/test/builtins/CMakeLists.txt
index fa7a0f4ad..f37e46d3a 100644
--- a/test/builtins/CMakeLists.txt
+++ b/test/builtins/CMakeLists.txt
@@ -19,6 +19,11 @@ foreach(arch ${BUILTIN_SUPPORTED_ARCH})
set(BUILTINS_TEST_TARGET_ARCH ${arch})
string(TOLOWER "-${arch}-${OS_NAME}" BUILTINS_TEST_CONFIG_SUFFIX)
get_test_cc_for_arch(${arch} BUILTINS_TEST_TARGET_CC BUILTINS_TEST_TARGET_CFLAGS)
+ if (${arch} STREQUAL "armhf")
+ list(APPEND BUILTINS_TEST_TARGET_CFLAGS -fomit-frame-pointer -DCOMPILER_RT_ARMHF_TARGET)
+ string(REPLACE ";" " " BUILTINS_TEST_TARGET_CFLAGS "${BUILTINS_TEST_TARGET_CFLAGS}")
+ endif()
+
string(TOUPPER ${arch} ARCH_UPPER_CASE)
set(CONFIG_NAME ${ARCH_UPPER_CASE}${OS_NAME}Config)
configure_lit_site_cfg(