summaryrefslogtreecommitdiff
path: root/test/builtins/CMakeLists.txt
diff options
context:
space:
mode:
authorWeiming Zhao <weimingz@codeaurora.org>2017-03-11 19:40:24 +0000
committerWeiming Zhao <weimingz@codeaurora.org>2017-03-11 19:40:24 +0000
commit5acb49fe6ad9d0a3e9eb0ae52c6fb67443d817c0 (patch)
treeae703ae9615546cf5639660430765a9dfef770c4 /test/builtins/CMakeLists.txt
parentac5f53a2fb91850b607a6b663cb1845105b23ab8 (diff)
[Builtin] Implement lit-test support
Summary: This patch implements a initial support of lit test for builtins. Unit/arm/call_apsr.S is updated to support thumb1. It also fixes a bug in arm/aeabi_uldivmod_test.c gcc_personality_test is XFAILED as the framework cannot handle it so far. cpu_model_test is also XFAILED for now as it is expected to return non-zero. Reviewers: rengolin, compnerd, jroelofs, erik.pilkington, arphaman Reviewed By: jroelofs Subscribers: jroelofs, aemerson, srhines, nemanjai, llvm-commits, mgorny Differential Revision: https://reviews.llvm.org/D30802 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@297566 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/builtins/CMakeLists.txt')
-rw-r--r--test/builtins/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/test/builtins/CMakeLists.txt b/test/builtins/CMakeLists.txt
index 443e552f8..b892f4eaf 100644
--- a/test/builtins/CMakeLists.txt
+++ b/test/builtins/CMakeLists.txt
@@ -9,6 +9,22 @@ configure_lit_site_cfg(
${CMAKE_CURRENT_BINARY_DIR}/lit.site.cfg
)
+#Unit tests.
+set(BUILTINS_TEST_ARCH ${COMPILER_RT_SUPPORTED_ARCH})
+
+foreach(arch ${BUILTINS_TEST_ARCH})
+ set(BUILTINS_TEST_TARGET_ARCH ${arch})
+ string(TOLOWER "-${arch}-${OS_NAME}" BUILTINS_TEST_CONFIG_SUFFIX)
+ get_test_cc_for_arch(${arch} BUILTINS_TEST_TARGET_CC BUILTINS_TEST_TARGET_CFLAGS)
+ string(TOUPPER ${arch} ARCH_UPPER_CASE)
+ set(CONFIG_NAME ${ARCH_UPPER_CASE}${OS_NAME}Config)
+ configure_lit_site_cfg(
+ ${CMAKE_CURRENT_SOURCE_DIR}/Unit/lit.site.cfg.in
+ ${CMAKE_CURRENT_BINARY_DIR}/Unit/${CONFIG_NAME}/lit.site.cfg
+ )
+ list(APPEND BUILTINS_TESTSUITES ${CMAKE_CURRENT_BINARY_DIR}/Unit/${CONFIG_NAME})
+endforeach()
+
add_lit_testsuite(check-builtins "Running the Builtins tests"
${BUILTINS_TESTSUITES}
DEPENDS ${BUILTINS_TEST_DEPS})