summaryrefslogtreecommitdiff
path: root/test/asan/CMakeLists.txt
diff options
context:
space:
mode:
authorReid Kleckner <rnk@google.com>2016-03-22 01:14:36 +0000
committerReid Kleckner <rnk@google.com>2016-03-22 01:14:36 +0000
commit0cd4db6dd4b255f8821cfc1239fbe9fa270a1386 (patch)
treee0495c433e67678beac569a56e9383d85b9c78c5 /test/asan/CMakeLists.txt
parent32897ea25860cbe5d50ce21e7e200d4e38a0ce11 (diff)
Move -fms-compatibility-version=19 into target cflags
This reduces cflags duplication and allows us to build sanitizer_common/tests with clang and the VS 2015 STL. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@264017 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/asan/CMakeLists.txt')
-rw-r--r--test/asan/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/test/asan/CMakeLists.txt b/test/asan/CMakeLists.txt
index 3a1abc87c..b2be95720 100644
--- a/test/asan/CMakeLists.txt
+++ b/test/asan/CMakeLists.txt
@@ -29,13 +29,6 @@ if(APPLE)
darwin_filter_host_archs(ASAN_SUPPORTED_ARCH ASAN_TEST_ARCH)
endif()
-# Extract the major version from CMake's MSVC_VERSION variable and pass it into
-# the lit configuration.
-set(MSVC_MAJOR_VERSION "")
-if (MSVC)
- string(SUBSTRING "${MSVC_VERSION}" 0 2 MSVC_MAJOR_VERSION)
-endif()
-
foreach(arch ${ASAN_TEST_ARCH})
if(ANDROID)
set(ASAN_TEST_TARGET_ARCH ${arch}-android)