summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2016-01-08 19:46:18 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2016-01-08 19:46:18 +0000
commitd557d12c906860baff06d58766332f933ac38d1d (patch)
tree73e00a7ca781c13d5b3798827cb592642f29f12b /test/CMakeLists.txt
parent80d54e07fe44811de19dbab5df3372a753879035 (diff)
Fix CMake warning in CFI tests.
Fix incorrect condition for enabling the CFI tests. This removes the following CMake warnings on Windows: The dependency target "cfi" of target "check-all" does not exist. The dependency target "cfi" of target "check-cfi-and-supported" does not exist. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@257199 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index e5c51c8cd..54132f342 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -61,7 +61,7 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
add_subdirectory(ubsan)
endif()
# CFI tests require diagnostic mode, which is implemented in UBSan.
- if(COMPILER_RT_HAS_UBSAN)
+ if(COMPILER_RT_HAS_CFI AND COMPILER_RT_HAS_UBSAN)
add_subdirectory(cfi)
endif()
if(COMPILER_RT_HAS_SAFESTACK)