summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-09-01 18:26:51 +0000
committerChris Bieneman <beanz@apple.com>2016-09-01 18:26:51 +0000
commit62aa8095ed282900f73ece10e26e89337aabb681 (patch)
tree47f19e1e943831b628f094bd6620533becde0ec9 /test/CMakeLists.txt
parentab564a89b2ffb304cd04a105f876c58e3dfad364 (diff)
[CMake] Adding compiler-rt-test-depends target
This exposes a target for building the compiler-rt test dependencies and matches llvm-test-depends. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@280393 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index b910122a5..f9d8fe80e 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -96,5 +96,6 @@ if(COMPILER_RT_STANDALONE_BUILD)
if(NOT TARGET check-all)
add_custom_target(check-all)
endif()
+ add_custom_target(compiler-rt-test-depends DEPENDS ${LLVM_LIT_DEPENDS})
add_dependencies(check-all check-compiler-rt)
endif()