summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDean Michael Berris <dberris@google.com>2016-08-08 03:10:22 +0000
committerDean Michael Berris <dberris@google.com>2016-08-08 03:10:22 +0000
commit585545f941de14c15784e9638a00da2ac4df5ed7 (patch)
treec4a03742fc09b9b3d3ecf05b6e5c5d2a483a790f /test/CMakeLists.txt
parent790fa40271e6c8b4e4c5994ad4b0303201639dab (diff)
[compiler-rt][XRay] Implement __xray_unpatch() and __xray_remove_handler()
Summary: We also add one test (and the XRay testing infrastructure) to exercise the patching and unpatching code. This uses the XRay API exported through the headers as well, installing a custom log handler. Depends on D23101 for the updated emitted code alignment for the return/entry sleds. Reviewers: rSerge, echristo, rnk Subscribers: tberghammer, danalbert, srhines, mehdi_amini, llvm-commits Differential Revision: https://reviews.llvm.org/D23154 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@277971 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 87548d94d..3316e0021 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -79,6 +79,9 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
if(COMPILER_RT_HAS_SCUDO)
add_subdirectory(scudo)
endif()
+ if(COMPILER_RT_HAS_XRAY)
+ add_subdirectory(xray)
+ endif()
endif()
if(COMPILER_RT_STANDALONE_BUILD)