summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <vonosmas@gmail.com>2015-09-29 21:43:37 +0000
committerAlexey Samsonov <vonosmas@gmail.com>2015-09-29 21:43:37 +0000
commitef066200d420b27069fd793835c8927ed1eb5563 (patch)
treef2894ec13dccc7f0e7dfacabc919383160b28eb7 /test/CMakeLists.txt
parent89fbf48c3f234712be522e62591a9cb137adb69d (diff)
[CFI] Make CFI tests require UBSan (for diagnostic mode).
CFI itself, on the other hand, doesn't require anything, including sanitizer_common. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@248830 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 6c898f476..684b409bb 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -60,7 +60,10 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
if(COMPILER_RT_HAS_UBSAN)
add_subdirectory(ubsan)
endif()
- add_subdirectory(cfi)
+ # CFI tests require diagnostic mode, which is implemented in UBSan.
+ if(COMPILER_RT_HAS_UBSAN)
+ add_subdirectory(cfi)
+ endif()
if(COMPILER_RT_HAS_SAFESTACK)
add_subdirectory(safestack)
endif()