summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-02-20 12:36:26 +0000
committerAlexey Samsonov <samsonov@google.com>2014-02-20 12:36:26 +0000
commite6699c4832464106d60fcb9c1da5a645cc6c3839 (patch)
tree03dd547f11f46e813f9c035e9d12bd9de1f688a1 /test/CMakeLists.txt
parentc7831b17590a6754e3471a995cc56a569318c172 (diff)
[CMake] Introduce check-all command for standalone compiler-rt build
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@201780 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 8a0fa2b09..a714cdfa5 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -46,3 +46,14 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
add_subdirectory(ubsan)
endif()
endif()
+
+if(COMPILER_RT_STANDALONE_BUILD)
+ # Now that we've traversed all the directories and know all the lit testsuites,
+ # introduce a rule to run to run all of them.
+ get_property(LLVM_LIT_TESTSUITES GLOBAL PROPERTY LLVM_LIT_TESTSUITES)
+ get_property(LLVM_LIT_DEPENDS GLOBAL PROPERTY LLVM_LIT_DEPENDS)
+ add_lit_target(check-all
+ "Running all regression tests"
+ ${LLVM_LIT_TESTSUITES}
+ DEPENDS ${LLVM_LIT_DEPENDS})
+endif()