summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2016-01-08 19:56:45 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2016-01-08 19:56:45 +0000
commite5588588640cf5e8203f7e4a319b88c909d41dcd (patch)
tree5620d4aad2fe783ee32b46b8bf12ab5df8d86e69 /test/CMakeLists.txt
parentd557d12c906860baff06d58766332f933ac38d1d (diff)
Revert "Fix CMake warning in CFI tests."
This is a bit more complex than that. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@257201 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 54132f342..e5c51c8cd 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -61,7 +61,7 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
add_subdirectory(ubsan)
endif()
# CFI tests require diagnostic mode, which is implemented in UBSan.
- if(COMPILER_RT_HAS_CFI AND COMPILER_RT_HAS_UBSAN)
+ if(COMPILER_RT_HAS_UBSAN)
add_subdirectory(cfi)
endif()
if(COMPILER_RT_HAS_SAFESTACK)