summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorReid Kleckner <reid@kleckner.net>2014-11-21 23:09:51 +0000
committerReid Kleckner <reid@kleckner.net>2014-11-21 23:09:51 +0000
commitcaa244c3092047b8b9a0be8f2ad5d58c5aa2b4dc (patch)
treee309d958bc89011da6993dd4c788725f3d9ab1b9 /test/CMakeLists.txt
parent8793336ca194c560f7930ae598200371d3dd40f4 (diff)
Don't make check-sanitizer depend on profile on Windows
We don't build the profiling library on Windows, so CMake warns that the target doesn't exist. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@222588 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 007ac3ff3..2ceb86463 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -14,7 +14,10 @@ if(NOT ANDROID)
# Use LLVM utils and Clang from the same build tree.
list(APPEND SANITIZER_COMMON_LIT_TEST_DEPS
clang clang-headers FileCheck count not llvm-nm llvm-symbolizer
- compiler-rt-headers profile)
+ compiler-rt-headers)
+ if (COMPILER_RT_HAS_PROFILE)
+ list(APPEND SANITIZER_COMMON_LIT_TEST_DEPS profile)
+ endif()
endif()
if(UNIX)
list(APPEND SANITIZER_COMMON_LIT_TEST_DEPS SanitizerLintCheck)