summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2017-08-31 22:26:34 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2017-08-31 22:26:34 +0000
commitc7cde8a5c61d9fe2a74e6e95b114e1022e7cccba (patch)
tree26fa0178bb965fd000f38998a13d19e730812f16 /test/CMakeLists.txt
parentfcb6aa26f41fd7544842e5d45ef4a125439a04af (diff)
[ubsan] Make check-ubsan depend on check-ubsan-minimal.
Summary: This way we don't need to add check-ubsan-minimal steps to all the bots. Reviewers: vitalybuka Subscribers: mgorny, llvm-commits Differential Revision: https://reviews.llvm.org/D37350 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@312291 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 2e344056f..341618554 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -71,6 +71,10 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
endforeach()
compiler_rt_test_runtime(profile)
+
+ if(COMPILER_RT_HAS_UBSAN AND COMPILER_RT_HAS_UBSAN_MINIMAL)
+ add_dependencies(check-ubsan check-ubsan-minimal)
+ endif()
endif()
if(COMPILER_RT_BUILD_XRAY)
compiler_rt_test_runtime(xray)