summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <vonosmas@gmail.com>2014-08-08 22:01:20 +0000
committerAlexey Samsonov <vonosmas@gmail.com>2014-08-08 22:01:20 +0000
commitbeab84b64ef5547c6b1eb19654cc90071e60fbf5 (patch)
tree4816c0e4017558fb9e6914fe4f06a478f1516024 /test/CMakeLists.txt
parenta7ff1013793a63f96e2ca652c369f6751ef1bd5d (diff)
[CMake] Determine which compiler-rt libraries are supported on
a given platform in a top-level CMakeLists.txt to use it both in lib/ and in test/ subdirectories. Move architecture/platform checks to config-ix. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@215247 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 847721635..ed5f1ee5d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -24,28 +24,28 @@ endif()
# Run sanitizer tests only if we're sure that clang would produce
# working binaries.
if(COMPILER_RT_CAN_EXECUTE_TESTS)
- if(ASAN_SUPPORTED_ARCH OR ANDROID)
+ if(COMPILER_RT_HAS_ASAN)
add_subdirectory(asan)
endif()
- if(DFSAN_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_DFSAN)
add_subdirectory(dfsan)
endif()
- if(LSAN_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_LSAN)
add_subdirectory(lsan)
endif()
- if(MSAN_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_MSAN)
add_subdirectory(msan)
endif()
- if(PROFILE_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_PROFILE)
add_subdirectory(profile)
endif()
- if(SANITIZER_COMMON_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_SANITIZER_COMMON)
add_subdirectory(sanitizer_common)
endif()
- if(TSAN_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_TSAN)
add_subdirectory(tsan)
endif()
- if(UBSAN_SUPPORTED_ARCH)
+ if(COMPILER_RT_HAS_UBSAN)
add_subdirectory(ubsan)
endif()
endif()