summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDuncan P. N. Exon Smith <dexonsmith@apple.com>2014-03-31 22:45:37 +0000
committerDuncan P. N. Exon Smith <dexonsmith@apple.com>2014-03-31 22:45:37 +0000
commita393c329b18213be8bfa9312785b415e4b017337 (patch)
treedc6718319bd8b651415674a8fb30eed1898c13d3 /test/CMakeLists.txt
parente1610ce7f8b49c4c4bc5d1992a9dbf9fbdc1a516 (diff)
InstrProf: Add simple compiler-rt test
Add the test infrastructure for testing lib/profile and a single test. This initial commit only enables the tests on Darwin, but they'll be enabled on Linux soon after. <rdar://problem/16458307> git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@205256 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index a714cdfa5..847721635 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -36,6 +36,9 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
if(MSAN_SUPPORTED_ARCH)
add_subdirectory(msan)
endif()
+ if(PROFILE_SUPPORTED_ARCH)
+ add_subdirectory(profile)
+ endif()
if(SANITIZER_COMMON_SUPPORTED_ARCH)
add_subdirectory(sanitizer_common)
endif()