summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorErik Pilkington <erik.pilkington@gmail.com>2017-03-09 15:58:26 +0000
committerErik Pilkington <erik.pilkington@gmail.com>2017-03-09 15:58:26 +0000
commit9a110981fc8e0d28844afd76f655cf5cd1c72754 (patch)
tree714521090a310969f2dd45767fbd95acb5b848a5 /test/CMakeLists.txt
parent7eba3f4c72c72961cdb85eed9d94330f81291e21 (diff)
Revert "[compiler-rt][builtins] Add __isOSVersionAtLeast()"
This reverts r297382, it was causing build failures. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@297388 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index addc57997..9b9c515a3 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -5,8 +5,9 @@ configure_lit_site_cfg(
${CMAKE_CURRENT_SOURCE_DIR}/lit.common.configured.in
${CMAKE_CURRENT_BINARY_DIR}/lit.common.configured)
-# BlocksRuntime (and most of builtins) testsuites are not yet ported to lit.
+# BlocksRuntime and builtins testsuites are not yet ported to lit.
# add_subdirectory(BlocksRuntime)
+# add_subdirectory(builtins)
set(SANITIZER_COMMON_LIT_TEST_DEPS)
if(COMPILER_RT_STANDALONE_BUILD)
@@ -38,9 +39,6 @@ endif()
# Run sanitizer tests only if we're sure that clang would produce
# working binaries.
if(COMPILER_RT_CAN_EXECUTE_TESTS)
- if(COMPILER_RT_BUILD_BUILTINS)
- add_subdirectory(builtins)
- endif()
if(COMPILER_RT_HAS_ASAN)
add_subdirectory(asan)
endif()