summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorVedant Kumar <vsk@apple.com>2017-09-18 18:13:47 +0000
committerVedant Kumar <vsk@apple.com>2017-09-18 18:13:47 +0000
commit6a0bc1fdc9f713f4cc9a89866dab7d66135519a9 (patch)
tree54469e6ba5c28f49c8fdfe027e06b3988406f45d /test/CMakeLists.txt
parentf951abe9908d2034b99e579e8b88afab5b7a7d24 (diff)
[cmake] Make it possible to build and test profile without sanitizers
This should fix an issue which arises when running check-compiler-rt on the coverage bot: http://green.lab.llvm.org/green/job/clang-stage2-coverage-R_build/1590/ The bot doesn't build the sanitizers, but the check-compiler-rt target always expects the profile runtime to exist. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@313549 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 6bc7cdbec..e691eab7d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -71,7 +71,8 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
compiler_rt_test_runtime(${sanitizer})
endif()
endforeach()
-
+ endif()
+ if (COMPILER_RT_HAS_PROFILE)
compiler_rt_test_runtime(profile)
endif()
if(COMPILER_RT_BUILD_XRAY)