summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorFilipe Cabecinhas <me@filcab.net>2015-02-20 03:41:07 +0000
committerFilipe Cabecinhas <me@filcab.net>2015-02-20 03:41:07 +0000
commit4b94e35618ef074ec689b3fa0c8e96b137d6e946 (patch)
tree9c128774d0b8f47848baec6072977f54360b93c1 /test/CMakeLists.txt
parent7f4f58ef606ffcdbe9cf7b0cfd1b892680043577 (diff)
Make FileCheck be a common dependency, not an ASan one.
Summary: It still gets picked up by ASan, but it also gets picked up by the other test suites. Otherwise, some test suites (e.g: UBSan) would complain they had no dependencies, and wouldn't run. Reviewers: samsonov, eugenis Subscribers: llvm-commits Differential Revision: http://reviews.llvm.org/D7740 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@229962 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 2ceb86463..dd3cbe9ad 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -7,6 +7,12 @@ configure_lit_site_cfg(
# add_subdirectory(builtins)
set(SANITIZER_COMMON_LIT_TEST_DEPS)
+if(COMPILER_RT_STANDALONE_BUILD)
+ add_executable(FileCheck IMPORTED GLOBAL)
+ set_property(TARGET FileCheck PROPERTY IMPORTED_LOCATION ${LLVM_TOOLS_BINARY_DIR}/FileCheck)
+ list(APPEND SANITIZER_COMMON_LIT_TEST_DEPS FileCheck)
+endif()
+
# When ANDROID, we build tests with the host compiler (i.e. CMAKE_C_COMPILER),
# and run tests with tools from the host toolchain.
if(NOT ANDROID)