summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-08-19 22:17:48 +0000
committerChris Bieneman <beanz@apple.com>2016-08-19 22:17:48 +0000
commit41ebd2701fa4722a2671be8c114eebfd7d5eeb2e (patch)
tree7b74f1c8c1c081eac09c1b99a14518a8f1821675 /test/CMakeLists.txt
parenta213e3e44fee034612344496915a649fd75a8f57 (diff)
[CMake] Add check-compiler-rt target for runtimes build
Durning standalone builds (which includes runtimes builds) we want to create a target named check-compiler-rt. Additionally we also create check-all if it doesn't already exist as a convienence target that depends on check-compiler-rt. This allows us to generate a single check target that invokes lit for all test suites in the runtimes projects, while avoiding name collision of check-all and not breaking existing workflows. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@279334 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 3316e0021..b910122a5 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -89,8 +89,12 @@ if(COMPILER_RT_STANDALONE_BUILD)
# introduce a rule to run to run all of them.
get_property(LLVM_LIT_TESTSUITES GLOBAL PROPERTY LLVM_LIT_TESTSUITES)
get_property(LLVM_LIT_DEPENDS GLOBAL PROPERTY LLVM_LIT_DEPENDS)
- add_lit_target(check-all
+ add_lit_target(check-compiler-rt
"Running all regression tests"
${LLVM_LIT_TESTSUITES}
DEPENDS ${LLVM_LIT_DEPENDS})
+ if(NOT TARGET check-all)
+ add_custom_target(check-all)
+ endif()
+ add_dependencies(check-all check-compiler-rt)
endif()