summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-02-14 11:42:22 +0000
committerAlexey Samsonov <samsonov@google.com>2014-02-14 11:42:22 +0000
commit2cac0ee49af612c518213a14022c6b0c08fb5e7b (patch)
treea46446ceefa1a4befd8359427a6bb26a3651549b /test/CMakeLists.txt
parent2c44cbe210a9f88a50489446202c4cb5e974744e (diff)
Move UBSan test suite under test/
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@201401 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 1ab0cb522..b497550ea 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -5,3 +5,11 @@ configure_lit_site_cfg(
# BlocksRuntime and builtins testsuites are not yet ported to lit.
# add_subdirectory(BlocksRuntime)
# add_subdirectory(builtins)
+
+# Run sanitizer tests only if we're sure that clang would produce
+# working binaries.
+if(COMPILER_RT_CAN_EXECUTE_TESTS)
+ if(UBSAN_SUPPORTED_ARCH)
+ add_subdirectory(ubsan)
+ endif()
+endif()