summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorEtienne Bergeron <etienneb@google.com>2016-07-27 15:29:49 +0000
committerEtienne Bergeron <etienneb@google.com>2016-07-27 15:29:49 +0000
commit1b184ea395ef74d1b9339b5186ca15ca70003c8a (patch)
treee011fd5c402d260e4fd98ca05df3caf56fa1415a /test/CMakeLists.txt
parente6d32453fdf31ea68cc57cf9726433309620d8c1 (diff)
[compiler-rt] Activate interception unittests
Summary: The unittests recently added were not running when executing 'check-all'. Tests are stable on every archictetures and we can now turn them on. Reviewers: rnk Subscribers: llvm-commits, wang0109, chrisha Differential Revision: https://reviews.llvm.org/D22695 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@276881 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 03d4571e0..87548d94d 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -45,6 +45,9 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
if(COMPILER_RT_HAS_DFSAN)
add_subdirectory(dfsan)
endif()
+ if (COMPILER_RT_HAS_INTERCEPTION)
+ add_subdirectory(interception)
+ endif()
if(COMPILER_RT_HAS_LSAN)
add_subdirectory(lsan)
endif()