summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancis Ricci <francisjricci@gmail.com>2017-06-27 19:52:35 +0000
committerFrancis Ricci <francisjricci@gmail.com>2017-06-27 19:52:35 +0000
commit1a427fa56cbea4e65c1f01e25b3cf91da78eadad (patch)
tree329ef296e4d24dfac5bf95d1a1705d0c416ea3d4 /test/CMakeLists.txt
parent2dcc25721dcf6329b8a0cb0f526996a8e841f8bb (diff)
Don't double-include cfi tests on linux
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@306455 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 0a6c11c34..9b4759dfb 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -60,7 +60,10 @@ if(COMPILER_RT_CAN_EXECUTE_TESTS)
compiler_rt_test_runtime(sanitizer_common)
foreach(sanitizer ${COMPILER_RT_SANITIZERS_TO_BUILD})
- compiler_rt_test_runtime(${sanitizer})
+ # cfi testing is gated on ubsan
+ if(NOT ${sanitizer} STREQUAL cfi)
+ compiler_rt_test_runtime(${sanitizer})
+ endif()
endforeach()
compiler_rt_test_runtime(profile)