summaryrefslogtreecommitdiff
path: root/lib/xray/CMakeLists.txt
diff options
context:
space:
mode:
authorDean Michael Berris <dberris@google.com>2018-05-04 06:13:35 +0000
committerDean Michael Berris <dberris@google.com>2018-05-04 06:13:35 +0000
commiteebc67fc29382a7505890e517e1d9eedae5c4f57 (patch)
tree2dc38831223fecfe4ec03a5318464b170579195d /lib/xray/CMakeLists.txt
parent3e5a6035832014f79af2ea233377bceddf22b9c4 (diff)
[XRay][compiler-rt] Support string-based config for FDR mode
Summary: In this chage we add support for the string-based configuration mechanism for configuring FDR mode. We deprecate most of the `xray_fdr_log_*` flags that are set with the `XRAY_OPTIONS` environment variable. Instead we make the FDR implementation take defaults from the `XRAY_FDR_OPTIONS` environment variable, and use the flags defined in `xray_fdr_flags.{h,cc,inc}` for the options we support. This change addresses http://llvm.org/PR36790. Depends on D46173. Reviewers: eizan, pelikan, kpw, echristo Subscribers: llvm-commits, mgorny Differential Revision: https://reviews.llvm.org/D46174 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@331506 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/xray/CMakeLists.txt')
-rw-r--r--lib/xray/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/xray/CMakeLists.txt b/lib/xray/CMakeLists.txt
index 22aa4d3de..58b566576 100644
--- a/lib/xray/CMakeLists.txt
+++ b/lib/xray/CMakeLists.txt
@@ -10,6 +10,7 @@ set(XRAY_SOURCES
# Implementation files for all XRay modes.
set(XRAY_FDR_MODE_SOURCES
+ xray_fdr_flags.cc
xray_buffer_queue.cc
xray_fdr_logging.cc)