summaryrefslogtreecommitdiff
path: root/lib/xray/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2016-07-20 21:37:38 +0000
committerHans Wennborg <hans@hanshq.net>2016-07-20 21:37:38 +0000
commit3261cf3c2813d79b53997498781503eaad6dd2f7 (patch)
treed0d6bb1eadbdbf005a12965e6e571985826513de /lib/xray/CMakeLists.txt
parent3aa2882179d440943c3b3750b1600039785bf7c6 (diff)
Revert r276117 "[XRay] Basic initialization and flag definition for XRay runtime"
and also the follow-up "[xray] Only build xray on Linux for now" Two build errors were reported on the llvm-commits list: [ 88%] Building CXX object lib/xray/CMakeFiles/clang_rt.xray-x86_64.dir/xray_flags.cc.o /mnt/b/sanitizer-buildbot1/sanitizer-x86_64-linux/build/llvm/projects/compiler-rt/lib/xray/xray_init.cc:23:10: fatal error: 'llvm/Support/ELF.h' file not found #include "llvm/Support/ELF.h" ^ and In file included from /w/src/llvm.org/projects/compiler-rt/lib/xray/xray_interface.cc:16: /w/src/llvm.org/projects/compiler-rt/lib/xray/xray_interface_internal.h:36:8: error: no type named 'size_t' in namespace 'std' std::size_t Entries; ~~~~~^ git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@276186 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/xray/CMakeLists.txt')
-rw-r--r--lib/xray/CMakeLists.txt47
1 files changed, 0 insertions, 47 deletions
diff --git a/lib/xray/CMakeLists.txt b/lib/xray/CMakeLists.txt
deleted file mode 100644
index 9b37a8ef8..000000000
--- a/lib/xray/CMakeLists.txt
+++ /dev/null
@@ -1,47 +0,0 @@
-# Build for the XRay runtime support library.
-
-set(XRAY_SOURCES
- xray_init.cc
- xray_interface.cc
- xray_flags.cc
-)
-
-set(x86_64_SOURCES
- xray_trampoline_x86.S
- ${XRAY_SOURCES})
-
-include_directories(..)
-include_directories(../../include)
-
-set(XRAY_CFLAGS ${SANITIZER_COMMON_CFLAGS})
-
-set(XRAY_COMMON_DEFINITIONS XRAY_HAS_EXCEPTIONS=1)
-
-add_compiler_rt_object_libraries(RTXray
- ARCHS ${XRAY_SUPPORTED_ARCH}
- SOURCES ${XRAY_SOURCES} CFLAGS ${XRAY_CFLAGS}
- DEFS ${XRAY_COMMON_DEFINITIONS})
-
-add_custom_target(xray)
-set(XRAY_COMMON_RUNTIME_OBJECT_LIBS
- RTSanitizerCommon
- RTSanitizerCommonLibc)
-
-foreach (arch ${XRAY_SUPPORTED_ARCH})
- if (CAN_TARGET_${arch})
- add_compiler_rt_runtime(clang_rt.xray
- STATIC
- ARCHS ${arch}
- SOURCES ${${arch}_SOURCES}
- CFLAGS ${XRAY_CFLAGS}
- DEFS ${XRAY_COMMON_DEFINITIONS}
- OBJECT_LIBS ${XRAY_COMMON_RUNTIME_OBJECT_LIBS}
- PARENT_TARGET xray)
- endif ()
-endforeach()
-
-add_dependencies(compiler-rt xray)
-
-# if(COMPILER_RT_INCLUDE_TESTS)
-# add_subdirectory(tests)
-# endif()