summaryrefslogtreecommitdiff
path: root/lib/xray/CMakeLists.txt
diff options
context:
space:
mode:
authorKuba Mracek <mracek@apple.com>2017-11-29 19:27:25 +0000
committerKuba Mracek <mracek@apple.com>2017-11-29 19:27:25 +0000
commit0a7288064854a3ff716d928a0ab72fdd2bbddb72 (patch)
tree81d7453cf3a8ab393d237a36826baf7546699664 /lib/xray/CMakeLists.txt
parent17c071e3dcbb1ee6d107a12096ec26750fb816c0 (diff)
[sanitizer] Refactor how assembly files are handled
This renames ASM_TSAN_SYMBOL and ASM_TSAN_SYMBOL_INTERCEPTOR to just ASM_SYMBOL and ASM_SYMBOL_INTERCEPTOR, because they can be useful in more places than just TSan. Also introduce a CMake function to add ASM sources to a target. Differential Revision: https://reviews.llvm.org/D40143 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@319339 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/xray/CMakeLists.txt')
-rw-r--r--lib/xray/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/lib/xray/CMakeLists.txt b/lib/xray/CMakeLists.txt
index dcf0efc72..fd00f3a40 100644
--- a/lib/xray/CMakeLists.txt
+++ b/lib/xray/CMakeLists.txt
@@ -66,13 +66,7 @@ set(XRAY_COMMON_RUNTIME_OBJECT_LIBS
if (APPLE)
set(XRAY_LINK_LIBS ${SANITIZER_COMMON_LINK_LIBS})
- set(XRAY_ASM_SOURCES xray_trampoline_x86_64.S)
-
- if (${CMAKE_GENERATOR} STREQUAL "Xcode")
- enable_language(ASM)
- else()
- set_source_files_properties(${XRAY_ASM_SOURCES} PROPERTIES LANGUAGE C)
- endif()
+ add_asm_sources(XRAY_ASM_SOURCES xray_trampoline_x86_64.S)
add_weak_symbols("sanitizer_common" WEAK_SYMBOL_LINK_FLAGS)
add_weak_symbols("xray" WEAK_SYMBOL_LINK_FLAGS)