summaryrefslogtreecommitdiff
path: root/lib/ubsan/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaly Buka <vitalybuka@google.com>2017-09-18 22:47:36 +0000
committerVitaly Buka <vitalybuka@google.com>2017-09-18 22:47:36 +0000
commit9be9a94b09e5513dbf83bffca7e99589f7c4fa8a (patch)
treed2ee34a52f14d862ca45bbaf172a842be1f66fd7 /lib/ubsan/CMakeLists.txt
parent084609f437ce6bc03d716b612f441d9bc7aff1bf (diff)
Revert "[ubsan] Split ubsan_init_standalone"
Breaks build. This reverts commit r313583 and r313584. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@313585 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ubsan/CMakeLists.txt')
-rw-r--r--lib/ubsan/CMakeLists.txt15
1 files changed, 3 insertions, 12 deletions
diff --git a/lib/ubsan/CMakeLists.txt b/lib/ubsan/CMakeLists.txt
index 0375cffb9..a29c0eed9 100644
--- a/lib/ubsan/CMakeLists.txt
+++ b/lib/ubsan/CMakeLists.txt
@@ -10,6 +10,7 @@ set(UBSAN_SOURCES
set(UBSAN_STANDALONE_SOURCES
ubsan_diag_standalone.cc
+ ubsan_init_standalone.cc
)
set(UBSAN_CXXABI_SOURCES
@@ -63,7 +64,6 @@ if(APPLE)
OS ${SANITIZER_COMMON_SUPPORTED_OS}
ARCHS ${UBSAN_SUPPORTED_ARCH}
SOURCES ${UBSAN_STANDALONE_SOURCES}
- ubsan_init_standalone.cc
CFLAGS ${UBSAN_STANDALONE_CFLAGS})
add_weak_symbols("ubsan" WEAK_SYMBOL_LINK_FLAGS)
@@ -133,15 +133,7 @@ else()
# Initializer of standalone UBSan runtime.
add_compiler_rt_object_libraries(RTUbsan_standalone
ARCHS ${UBSAN_SUPPORTED_ARCH}
- SOURCES ${UBSAN_STANDALONE_SOURCES}
- ubsan_init_standalone
- CFLAGS ${UBSAN_STANDALONE_CFLAGS})
- # This can't not be linked into share lib
- add_compiler_rt_object_libraries(RTUbsan_standalone_preinit
- ARCHS ${UBSAN_SUPPORTED_ARCH}
- SOURCES ${UBSAN_STANDALONE_SOURCES}
- ubsan_init_standalone_preinit.cc
- CFLAGS ${UBSAN_STANDALONE_CFLAGS})
+ SOURCES ${UBSAN_STANDALONE_SOURCES} CFLAGS ${UBSAN_STANDALONE_CFLAGS})
# Standalone UBSan runtimes.
add_compiler_rt_runtime(clang_rt.ubsan_standalone
@@ -150,7 +142,7 @@ else()
OBJECT_LIBS RTSanitizerCommon
RTSanitizerCommonLibc
RTUbsan
- RTUbsan_standalone_preinit
+ RTUbsan_standalone
CFLAGS ${UBSAN_CFLAGS}
PARENT_TARGET ubsan)
@@ -168,7 +160,6 @@ else()
OBJECT_LIBS RTSanitizerCommon
RTSanitizerCommonLibc
RTUbsan
- RTUbsan_standalone
CFLAGS ${UBSAN_CFLAGS}
LINK_FLAGS ${SANITIZER_COMMON_LINK_FLAGS}
LINK_LIBS ${UBSAN_DYNAMIC_LIBS}