summaryrefslogtreecommitdiff
path: root/lib/ubsan/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-12-09 22:45:03 +0000
committerChris Bieneman <beanz@apple.com>2015-12-09 22:45:03 +0000
commit7fbd9917dcc3cb590205331b82d8efc7322de09b (patch)
treed739b38cd8e4037d64487ed66f26b5bc83437860 /lib/ubsan/CMakeLists.txt
parent30373afde77e6540e2768c164142af7d716cdb03 (diff)
[CMake] Provide options for toggling on and off various runtime libraries.
Summary: Rather than having to add new "experimental" options each time someone wants to work on bringing a sanitizer to a new platform, this patch makes options for all of them. The default values for the options are set by the platform checks that would have enabled them, but they can be overridden on or off. Reviewers: kubabrecka, samsonov Subscribers: llvm-commits Differential Revision: http://reviews.llvm.org/D14846 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@255170 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ubsan/CMakeLists.txt')
-rw-r--r--lib/ubsan/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/ubsan/CMakeLists.txt b/lib/ubsan/CMakeLists.txt
index 5ece9a62c..c447042c2 100644
--- a/lib/ubsan/CMakeLists.txt
+++ b/lib/ubsan/CMakeLists.txt
@@ -1,5 +1,7 @@
# Build for the undefined behavior sanitizer runtime support library.
+check_list_contains(COMPILER_RT_HAS_UBSAN COMPILER_RT_RUNTIMES_TO_BUILD ubsan)
+
set(UBSAN_SOURCES
ubsan_diag.cc
ubsan_init.cc