summaryrefslogtreecommitdiff
path: root/lib/ubsan/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaly Buka <vitalybuka@google.com>2017-09-18 22:38:18 +0000
committerVitaly Buka <vitalybuka@google.com>2017-09-18 22:38:18 +0000
commit7055da967bd6e8d188d6821bc1ab63bebfb363de (patch)
treee64cbc73c7efcf8faa9f632884331e68289a15d9 /lib/ubsan/CMakeLists.txt
parent474ec9e95dcb85850097b84c0017b44770dcecb7 (diff)
[ubsan] Split ubsan_init_standalone
On Linux we may need preinit_array in static lib and ubsan_standalone_initializer in shared lib. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@313583 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/ubsan/CMakeLists.txt')
-rw-r--r--lib/ubsan/CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/lib/ubsan/CMakeLists.txt b/lib/ubsan/CMakeLists.txt
index a29c0eed9..0375cffb9 100644
--- a/lib/ubsan/CMakeLists.txt
+++ b/lib/ubsan/CMakeLists.txt
@@ -10,7 +10,6 @@ set(UBSAN_SOURCES
set(UBSAN_STANDALONE_SOURCES
ubsan_diag_standalone.cc
- ubsan_init_standalone.cc
)
set(UBSAN_CXXABI_SOURCES
@@ -64,6 +63,7 @@ if(APPLE)
OS ${SANITIZER_COMMON_SUPPORTED_OS}
ARCHS ${UBSAN_SUPPORTED_ARCH}
SOURCES ${UBSAN_STANDALONE_SOURCES}
+ ubsan_init_standalone.cc
CFLAGS ${UBSAN_STANDALONE_CFLAGS})
add_weak_symbols("ubsan" WEAK_SYMBOL_LINK_FLAGS)
@@ -133,7 +133,15 @@ else()
# Initializer of standalone UBSan runtime.
add_compiler_rt_object_libraries(RTUbsan_standalone
ARCHS ${UBSAN_SUPPORTED_ARCH}
- SOURCES ${UBSAN_STANDALONE_SOURCES} CFLAGS ${UBSAN_STANDALONE_CFLAGS})
+ SOURCES ${UBSAN_STANDALONE_SOURCES}
+ ubsan_init_standalone
+ CFLAGS ${UBSAN_STANDALONE_CFLAGS})
+ # This can't not be linked into share lib
+ add_compiler_rt_object_libraries(RTUbsan_standalone_preinit
+ ARCHS ${UBSAN_SUPPORTED_ARCH}
+ SOURCES ${UBSAN_STANDALONE_SOURCES}
+ ubsan_init_standalone_preinit.cc
+ CFLAGS ${UBSAN_STANDALONE_CFLAGS})
# Standalone UBSan runtimes.
add_compiler_rt_runtime(clang_rt.ubsan_standalone
@@ -142,7 +150,7 @@ else()
OBJECT_LIBS RTSanitizerCommon
RTSanitizerCommonLibc
RTUbsan
- RTUbsan_standalone
+ RTUbsan_standalone_preinit
CFLAGS ${UBSAN_CFLAGS}
PARENT_TARGET ubsan)
@@ -160,6 +168,7 @@ else()
OBJECT_LIBS RTSanitizerCommon
RTSanitizerCommonLibc
RTUbsan
+ RTUbsan_standalone
CFLAGS ${UBSAN_CFLAGS}
LINK_FLAGS ${SANITIZER_COMMON_LINK_FLAGS}
LINK_LIBS ${UBSAN_DYNAMIC_LIBS}