summaryrefslogtreecommitdiff
path: root/lib/tsan/dd/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-03-31 13:45:36 +0000
committerAlexey Samsonov <samsonov@google.com>2014-03-31 13:45:36 +0000
commite18b78588ef4aac46204c7b23d076221993edade (patch)
tree8620e3e8c88fce96c2a48dc6650b8cd51f5e675c /lib/tsan/dd/CMakeLists.txt
parenteba4cc9092ffa0fb41c1b25491857f6f9b5b01e4 (diff)
[CMake] Rename add_compiler_rt_static_runtime to add_compiler_rt_runtime.
Soon there will be an option to build compiler-rt parts as shared libraries on Linux. Extracted from http://llvm-reviews.chandlerc.com/D3042 by Yuri Gribov. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@205183 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/tsan/dd/CMakeLists.txt')
-rw-r--r--lib/tsan/dd/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/tsan/dd/CMakeLists.txt b/lib/tsan/dd/CMakeLists.txt
index 305e26c07..a21e2dd57 100644
--- a/lib/tsan/dd/CMakeLists.txt
+++ b/lib/tsan/dd/CMakeLists.txt
@@ -26,7 +26,7 @@ add_custom_target(dd)
# Deadlock detector is currently supported on 64-bit Linux only.
if(CAN_TARGET_x86_64 AND UNIX AND NOT APPLE AND NOT ANDROID)
set(arch "x86_64")
- add_compiler_rt_static_runtime(clang_rt.dd-${arch} ${arch}
+ add_compiler_rt_runtime(clang_rt.dd-${arch} ${arch} STATIC
SOURCES ${DD_SOURCES}
$<TARGET_OBJECTS:RTInterception.${arch}>
$<TARGET_OBJECTS:RTSanitizerCommon.${arch}>