summaryrefslogtreecommitdiff
path: root/lib/tsan/dd/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-07-26 06:46:11 +0000
committerPetr Hosek <phosek@chromium.org>2017-07-26 06:46:11 +0000
commit99ae2fab3b53a1f0c17e17b2b045b488b52ae08a (patch)
tree20b2a16e43fa115de983c96de866333ba046da53 /lib/tsan/dd/CMakeLists.txt
parent8e31fff29bcbd5148e222e11130671bfe46de849 (diff)
Revert "[sanitizer] Support compiler-rt builtins"
This reverts commit fd63314d6770e0da62572a3fea2c41c4cc0fc58a. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@309083 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/tsan/dd/CMakeLists.txt')
-rw-r--r--lib/tsan/dd/CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/lib/tsan/dd/CMakeLists.txt b/lib/tsan/dd/CMakeLists.txt
index bd9515567..bcff35f20 100644
--- a/lib/tsan/dd/CMakeLists.txt
+++ b/lib/tsan/dd/CMakeLists.txt
@@ -10,12 +10,10 @@ set(DD_SOURCES
dd_interceptors.cc
)
-set(DD_LINKLIBS ${SANITIZER_COMMON_LINK_LIBS})
-
+set(DD_LINKLIBS)
append_list_if(COMPILER_RT_HAS_LIBDL dl DD_LINKLIBS)
append_list_if(COMPILER_RT_HAS_LIBRT rt DD_LINKLIBS)
append_list_if(COMPILER_RT_HAS_LIBPTHREAD pthread DD_LINKLIBS)
-append_list_if(COMPILER_RT_HAS_LIBSTDCXX stdc++ DD_LINKLIBS)
add_custom_target(dd)
# Deadlock detector is currently supported on 64-bit Linux only.
@@ -42,7 +40,6 @@ if(CAN_TARGET_x86_64 AND UNIX AND NOT APPLE AND NOT ANDROID)
$<TARGET_OBJECTS:RTInterception.${arch}>
$<TARGET_OBJECTS:RTSanitizerCommon.${arch}>
$<TARGET_OBJECTS:RTSanitizerCommonLibc.${arch}>
- LINK_FLAGS ${SANITIZER_COMMON_LINK_FLAGS}
LINK_LIBS ${DD_LINKLIBS}
PARENT_TARGET dd)
endif()