summaryrefslogtreecommitdiff
path: root/lib/tsan/dd/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2015-06-10 23:55:07 +0000
committerChris Bieneman <beanz@apple.com>2015-06-10 23:55:07 +0000
commit5c2fd24d4c819c96d678cc43c3cb9073bb2a6bd1 (patch)
treee8f847ab819dae8f5a5d7f0de9fdfbc6370ef3d4 /lib/tsan/dd/CMakeLists.txt
parent3856120598c388065825462f223c3868acbddd4d (diff)
[CMake] Cleanup add_compiler_rt_object_library to be platform-agnostic
Summary: This change takes darwin-specific goop that was scattered around CMakeLists files and spread between add_compiler_rt_object_library and add_compiler_rt_darwin_object_library and moves it all under add_compiler_rt_object_library. The goal of this is to try to push platform handling as low in the utility functions as possible. Reviewers: rnk, samsonov Reviewed By: rnk, samsonov Subscribers: rnk, rsmith, llvm-commits Differential Revision: http://reviews.llvm.org/D10250 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@239498 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/tsan/dd/CMakeLists.txt')
-rw-r--r--lib/tsan/dd/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/tsan/dd/CMakeLists.txt b/lib/tsan/dd/CMakeLists.txt
index 3ab214516..d7c604166 100644
--- a/lib/tsan/dd/CMakeLists.txt
+++ b/lib/tsan/dd/CMakeLists.txt
@@ -27,7 +27,8 @@ if(CAN_TARGET_x86_64 AND UNIX AND NOT APPLE AND NOT ANDROID)
CFLAGS ${DD_CFLAGS})
add_dependencies(dd clang_rt.dd-${arch})
- add_compiler_rt_object_library(RTDD ${arch}
+ add_compiler_rt_object_libraries(RTDD
+ ARCH ${arch}
SOURCES ${DD_SOURCES} CFLAGS ${DD_CFLAGS})
add_compiler_rt_runtime(clang_rt.dyndd-${arch} ${arch} SHARED