summaryrefslogtreecommitdiff
path: root/lib/tsan/CMakeLists.txt
diff options
context:
space:
mode:
authorEd Maste <emaste@freebsd.org>2016-02-18 17:35:30 +0000
committerEd Maste <emaste@freebsd.org>2016-02-18 17:35:30 +0000
commit6606c7b50cbb4ec7eab4ecbebbbaaa049734bbd3 (patch)
treecde8383ab792398f4ef80134fe18fb5489a94a1e /lib/tsan/CMakeLists.txt
parentf5d33e12577fdd1c397b71c144e16d11f5b149b9 (diff)
[tsan] Disable sysroot flag on FreeBSD
FreeBSD does not install a number of Clang-provided headers for the compiler in the base system due to incompatibilities between FreeBSD's and Clang's versions. As a workaround do not use --sysroot=. on FreeBSD until this is addressed. llvm.org/pr26651 Differential Revision: http://reviews.llvm.org/D17383 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@261229 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/tsan/CMakeLists.txt')
-rw-r--r--lib/tsan/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/lib/tsan/CMakeLists.txt b/lib/tsan/CMakeLists.txt
index c185cfa16..a151c6c6b 100644
--- a/lib/tsan/CMakeLists.txt
+++ b/lib/tsan/CMakeLists.txt
@@ -192,7 +192,11 @@ endif()
add_dependencies(compiler-rt tsan)
# Make sure that non-platform-specific files don't include any system headers.
-if(COMPILER_RT_HAS_SYSROOT_FLAG)
+# FreeBSD does not install a number of Clang-provided headers for the compiler
+# in the base system due to incompatibilities between FreeBSD's and Clang's
+# versions. As a workaround do not use --sysroot=. on FreeBSD until this is
+# addressed.
+if(COMPILER_RT_HAS_SYSROOT_FLAG AND NOT CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
file(GLOB _tsan_generic_sources rtl/tsan*)
file(GLOB _tsan_platform_sources rtl/tsan*posix* rtl/tsan*mac*
rtl/tsan*linux*)