summaryrefslogtreecommitdiff
path: root/lib/tsan/CMakeLists.txt
diff options
context:
space:
mode:
authorDmitri Gribenko <gribozavr@gmail.com>2015-02-22 12:20:05 +0000
committerDmitri Gribenko <gribozavr@gmail.com>2015-02-22 12:20:05 +0000
commit19c7ecf66cb7a15d024f974d2d02c0ed9fa5bfcf (patch)
tree8fe2a3753041bc8afcc276da6b914f9053ce24fb /lib/tsan/CMakeLists.txt
parent7e932b68bf5a5c06eb293c22611977e7c91a592b (diff)
Revert r230171 "TSan runtime: unbreak the build with ccache"
It broke a buildbot with a non-clang (?) compiler. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@230174 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/tsan/CMakeLists.txt')
-rw-r--r--lib/tsan/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/tsan/CMakeLists.txt b/lib/tsan/CMakeLists.txt
index 86db3bcc7..9f6d63041 100644
--- a/lib/tsan/CMakeLists.txt
+++ b/lib/tsan/CMakeLists.txt
@@ -89,7 +89,7 @@ if(UNIX AND NOT APPLE)
# Sanity check for Go runtime.
set(BUILDGO_SCRIPT ${CMAKE_CURRENT_SOURCE_DIR}/go/buildgo.sh)
add_custom_target(GotsanRuntimeCheck
- COMMAND env "CC=${CMAKE_C_COMPILER} ${CMAKE_C_COMPILER_ARG1}" IN_TMPDIR=1 SILENT=1 ${BUILDGO_SCRIPT}
+ COMMAND CC=${CMAKE_C_COMPILER} IN_TMPDIR=1 SILENT=1 ${BUILDGO_SCRIPT}
DEPENDS clang_rt.tsan-${arch} ${BUILDGO_SCRIPT}
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/go
COMMENT "Checking TSan Go runtime..."