summaryrefslogtreecommitdiff
path: root/lib/scudo/CMakeLists.txt
diff options
context:
space:
mode:
authorKostya Kortchinsky <kostyak@google.com>2018-04-12 16:41:57 +0000
committerKostya Kortchinsky <kostyak@google.com>2018-04-12 16:41:57 +0000
commit673f8a11a19433bc90a2cd0c31ba5a26980c9f00 (patch)
tree569b971c58f4c911c90c4d26fc328fb644fde523 /lib/scudo/CMakeLists.txt
parentfe404ca10611902b252d7c190288eb32af8dfc4a (diff)
[scudo] Remove duplicate cmake flags
Summary: Now that common options are propagated again for runtimes build with D45507, the -f{data,function}-sections flags are now duplicates, remove them. Reviewers: alekseyshl Reviewed By: alekseyshl Subscribers: mgorny, delcypher, #sanitizers, llvm-commits Differential Revision: https://reviews.llvm.org/D45575 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@329925 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/scudo/CMakeLists.txt')
-rw-r--r--lib/scudo/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/scudo/CMakeLists.txt b/lib/scudo/CMakeLists.txt
index 319bd3bb9..1e03fcd40 100644
--- a/lib/scudo/CMakeLists.txt
+++ b/lib/scudo/CMakeLists.txt
@@ -4,7 +4,7 @@ include_directories(..)
set(SCUDO_CFLAGS ${SANITIZER_COMMON_CFLAGS})
# SANITIZER_COMMON_CFLAGS include -fno-builtin, but we actually want builtins!
-list(APPEND SCUDO_CFLAGS -fbuiltin -ffunction-sections -fdata-sections)
+list(APPEND SCUDO_CFLAGS -fbuiltin)
append_rtti_flag(OFF SCUDO_CFLAGS)
set(SCUDO_DYNAMIC_LIBS ${SANITIZER_COMMON_LINK_LIBS})