summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorEvgeniy Stepanov <eugeni.stepanov@gmail.com>2015-07-24 19:00:16 +0000
committerEvgeniy Stepanov <eugeni.stepanov@gmail.com>2015-07-24 19:00:16 +0000
commitcb2f3918ab386da2a3541d1ef20d5bb839d469f5 (patch)
tree7d2659873b52999dbc19bb947130eb65384f1f0a /lib/sanitizer_common/tests/CMakeLists.txt
parent9208f205757b57e6a588d1899b9d9e7551b64423 (diff)
[asan] Only link liblog on Android when it exists.
With r242975, liblog is only used on certain older platforms. git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@243139 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/tests/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/sanitizer_common/tests/CMakeLists.txt b/lib/sanitizer_common/tests/CMakeLists.txt
index 342a73246..76ca78648 100644
--- a/lib/sanitizer_common/tests/CMakeLists.txt
+++ b/lib/sanitizer_common/tests/CMakeLists.txt
@@ -72,7 +72,7 @@ if(ANDROID)
endif()
set(SANITIZER_TEST_LINK_LIBS)
-append_list_if(ANDROID log SANITIZER_TEST_LINK_LIBS)
+append_list_if(COMPILER_RT_HAS_LIBLOG log SANITIZER_TEST_LINK_LIBS)
# NDK r10 requires -latomic almost always.
append_list_if(ANDROID atomic SANITIZER_TEST_LINK_LIBS)