summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2014-03-13 09:31:36 +0000
committerAlexey Samsonov <samsonov@google.com>2014-03-13 09:31:36 +0000
commit471b11cc0b977e4943395c718ef81ce767706298 (patch)
treed7ba094d45247ee62b5e04d55ee6337bd2ffd1d8 /lib/sanitizer_common/tests/CMakeLists.txt
parentaf905790774f263ee484991854037720c1fac373 (diff)
[CMake] Make append_if semantics similar to those used in LLVM
git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@203773 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/tests/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/tests/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/sanitizer_common/tests/CMakeLists.txt b/lib/sanitizer_common/tests/CMakeLists.txt
index 1e6b38b61..bf991dd93 100644
--- a/lib/sanitizer_common/tests/CMakeLists.txt
+++ b/lib/sanitizer_common/tests/CMakeLists.txt
@@ -42,8 +42,8 @@ set(SANITIZER_TEST_CFLAGS_COMMON
set(SANITIZER_TEST_LINK_FLAGS_COMMON
-lstdc++)
-append_if(SANITIZER_TEST_LINK_FLAGS_COMMON COMPILER_RT_HAS_LIBDL -ldl)
-append_if(SANITIZER_TEST_LINK_FLAGS_COMMON COMPILER_RT_HAS_LIBPTHREAD -lpthread)
+append_if(COMPILER_RT_HAS_LIBDL -ldl SANITIZER_TEST_LINK_FLAGS_COMMON)
+append_if(COMPILER_RT_HAS_LIBPTHREAD -lpthread SANITIZER_TEST_LINK_FLAGS_COMMON)
include_directories(..)
include_directories(../..)