summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Aizatsky <aizatsky@chromium.org>2015-11-11 01:26:57 +0000
committerMike Aizatsky <aizatsky@chromium.org>2015-11-11 01:26:57 +0000
commit7c95f2112d8fb3e23b0f41f1c43dea4d55039cba (patch)
tree3ff1fc80d88ade1dd9ad26eefebacb675d844255 /lib/sanitizer_common/CMakeLists.txt
parent4e5c2989d642ae5d9e7e3c2379a9f312c9d6e8a6 (diff)
Sancov in C++.
Summary: First batch of sancov.py rewrite in C++. Supports "-print" and "-covered_functions" commands. Differential Revision: http://reviews.llvm.org/D14356 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@252683 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index 6a20f0255..345362981 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -156,3 +156,6 @@ add_compiler_rt_object_libraries(RTSanitizerCommonLibc
if(COMPILER_RT_INCLUDE_TESTS)
add_subdirectory(tests)
endif()
+
+add_llvm_tool(sancov sancov.cc)
+target_link_libraries(sancov LLVMSupport LLVMSymbolize LLVMObject LLVMDebugInfoDWARF LLVMDebugInfoPDB)