summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorKamil Rytarowski <n54@gmx.com>2017-12-04 12:30:09 +0000
committerKamil Rytarowski <n54@gmx.com>2017-12-04 12:30:09 +0000
commit5551897294887d632c71275cf11c5654fd80cda7 (patch)
tree337a08e959e1c1891df9e7ce57169e052edadfb6 /lib/sanitizer_common/CMakeLists.txt
parent43dc46e9706f5efe709c0987098a2f3f235aa204 (diff)
Move __tsan::Vector to __sanitizer
Summary: The low-fat STL-like vector container will be reused in MSan. It is needed to implement an atexit(3) interceptor on NetBSD/amd64 in MSan. Sponsored by <The NetBSD Foundation> Reviewers: joerg, dvyukov, eugenis, vitalybuka, kcc Reviewed By: dvyukov Subscribers: kubamracek, mgorny, llvm-commits, #sanitizers Tags: #sanitizers Differential Revision: https://reviews.llvm.org/D40726 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@319650 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index db077b565..60caa5c4f 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -140,6 +140,7 @@ set(SANITIZER_HEADERS
sanitizer_syscall_linux_x86_64.inc
sanitizer_syscall_linux_aarch64.inc
sanitizer_thread_registry.h
+ sanitizer_vector.h
sanitizer_win.h)
include_directories(..)