summaryrefslogtreecommitdiff
path: root/lib/sanitizer_common/CMakeLists.txt
diff options
context:
space:
mode:
authorVedant Kumar <vsk@apple.com>2017-10-07 03:44:46 +0000
committerVedant Kumar <vsk@apple.com>2017-10-07 03:44:46 +0000
commit3d16ad721458f4efd52e3bb1ba53a75e001ea4bc (patch)
treeb813a39e894dc83225dd1f7523cee9a75e419a61 /lib/sanitizer_common/CMakeLists.txt
parentf41e67051268425df1cbbc1a208b8eba03875885 (diff)
Use list(APPEND) instead of append()
append() seems to be available with the version of cmake I'm using, but not on the bots: http://green.lab.llvm.org/green//job/clang-stage1-configure-RA/39354 git-svn-id: https://llvm.org/svn/llvm-project/compiler-rt/trunk@315144 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/sanitizer_common/CMakeLists.txt')
-rw-r--r--lib/sanitizer_common/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/sanitizer_common/CMakeLists.txt b/lib/sanitizer_common/CMakeLists.txt
index 691bf3b1f..e62b24544 100644
--- a/lib/sanitizer_common/CMakeLists.txt
+++ b/lib/sanitizer_common/CMakeLists.txt
@@ -200,7 +200,7 @@ add_compiler_rt_object_libraries(RTSanitizerCommonLibc
DEFS ${SANITIZER_COMMON_DEFINITIONS})
set(SANITIZER_NO_WEAK_HOOKS_CFLAGS ${SANITIZER_CFLAGS})
-append("-DSANITIZER_SUPPORTS_WEAK_HOOKS=0" SANITIZER_NO_WEAK_HOOKS_CFLAGS)
+list(APPEND SANITIZER_NO_WEAK_HOOKS_CFLAGS "-DSANITIZER_SUPPORTS_WEAK_HOOKS=0")
add_compiler_rt_object_libraries(RTSanitizerCommonNoHooks
${OS_OPTION}
ARCHS ${SANITIZER_COMMON_SUPPORTED_ARCH}